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Using Crystal Reports with VFP 

Introduction to Crystal Reports 

One of the most important aspects of Visual FoxPro applications is reporting. Whether we 

provide canned reports or allow the user to design their own, or provide the output as a printed 

report, a Word document, an Excel spreadsheet, or an Adobe Acrobat file, users are demanding 

more sophisticated reports. This is where Crystal Reports can make our job easier. Before 

proceeding too far, I should tell you that this document is based on Crystal Reports 8.  

Crystal Reports provides many of the capabilities missing in the VFP report writer. These 

include:  

 Multi-line headers, footers, and details. You can easily multiple lines to any 
section of the report and conditionally print those lines.  

 Graphing. This is as easy as selecting the type of graph you want and placing it 
in the section where you want it printed. Crystal Reports will handle all the 
formatting and data binding. You can also provide further customization.  

 Subreports. This feature allows you embed reports inside each other.  
 Drill-down. Distribute the Crystal Reports reader with your application to allow 

users to drill-down from summary to detail data in the same report.  
 Output options. Users can output their report in a number of formats including 

Excel, Word, RTF, HTML, or PDF and retain all formatting.  
 Web Reporting. Crystal Reports includes extensive web reporting capabilities 

that can be called from ASP pages.  
 Standard Reporting tool in Visual Studio.Net. For many years, VFP developers 

have wanted an enhanced report designer. A special version of Crystal Reports 
will be included in Visual Studio.Net.  

Accessing Fox Data 

When designing your report, you’ll most likely want to bind it to a data source. Crystal Reports 

can access VFP data in a number of ways:  

Á ADO. VFP 7.0 will ship with an OLE-DB provider.  
Á ODBC. This is currently the only way to access VFP data, but it is slow due to the 

overhead of the ODBC layer.  
Á Native Driver. Crystal Reports can directly read Fox2X data. This is by far the 

fastest way to access your data. My suggestion is to run a PRG that pulls all the 
needed data into a single cursor then COPY TO é FOX2X.  

Keep in mind that Crystal Reports cannot access cursors because they reside in FoxPro’s 

memory space. However, Crystal Reports can use views defined in the DBC via ODBC. 

Creating Reports 
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I’ll show you a couple of examples of creating reports. The first is a simple flat file using the 

Report Expert. The second is a more complicated, multi-table join using ODBC to connect to 

TasTrade. 

Example 1: A Simple Flat File 

To understand the report creating process, let’s walk through a simple example. In the first 

example, we’ll use a single table. Because Crystal Reports works better with Fox2X tables, USE 

the Customer table from the Tastrade example, then COPY TO C:\TEMP\Cust TYPE FOX2X. 

Launch Crystal Reports and select File > New. You’ll see the Report Gallery dialog. This dialog 

prompts you to select the type of report you want to design. The Report Expert is a Wizard that 

walks you through the report creation process.  

 

As you select different expert types, the picture in the right panel will change to represent the 

report. Select “Using the Report Expert” and a Standard report, then click OK.  

The Standard Report Expert will be displayed. The first step is to select all the tables to use in the 

report. Expand the “Database Files” leaf  then click on Find Database Files. Locate 

CUSTOMER.DBF that you created above. When you get back to the Data Explorer, make sure 

you select Add or the table won’t be available to your report. When a table is added, a check 

mark will appear next to it in the Data Explorer. Click Close to return to the Report Expert.  
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 The Fields tab allows you to select the fields to include from the select tables. Select 

COMPANY_NA, CITY, and COUNTRY. 
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Now click Finish to go to the report designer. The report will be displayed in the Preview 

window.  

 

You can now print or export the report. Select File > Print > Export. You’ll see the Export dialog 

that allows you to pick one of several formats. 

 

When you select OK, you’ll get a dialog prompting you for different information, depending on 

the export format you selected. 

Example 2: A Multi-table Report 

In this example, we’ll look at joining multiple tables to produce a more complicated report. This 

report will include multiple groupings and a bar chart. 

Before creating this report, you’ll need to create an ODBC connection to the TasTrade database. 

Once you have that connection, go back to Crystal Reports and select File > New. However, for 

this example, select Blank Report. The Data Explorer will be displayed. Expand the ODBC 
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options and then expand Tastrade. Add the files Customer, Orders, Order_Line_Items, and 

Products then close the Data Explorer. 

The Visual Linking Expert will then display. Crystal Reports looks for common fields in each 

table and attempts to link the tables together properly. 

 

As you can see, there are two connections that need to be removed. Click on the line connecting 

Customer.Discount to Orders.Discount. Press the Del key to remove the connection. Now 

remove the connection from Order_Line_Items.Unit_Price to Products.Unit_Price, then click 

OK. 

Drag the following fields from the Field Explorer and drop them onto the Details band of the 

report: Order_Line_Items.Order_Id, Products.Product_Name, Orders_Line_Items.Quantity, and 

Order_Line_Items.Unit_Price.  When you have added these fields, you can close the Field 

Explorer. 

We now need to add some groups. Select Insert > Group. From the Insert Group dialog, select 

Customer.Company_Name then click OK. 
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Now, let’s add a total price for each line item. This will require creating a Crystal Reports 

formula field. From the menu, select Insert > Formula Field, then click the New button on the 

Field Explorer Toolbar and enter the formula name “Extended Price”.  

 

The Formula Editor adds lots of power to Crystal Reports. Almost every attribute of every report 

object can have a formula attached to it. For example, you can have a number be red if it is 
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negative or black if positive. You can conditionally print a single object or an entire band. You 

can enter your formula in either Crystal syntax or BASIC syntax. For our example, we’ll use 

Crystal syntax.  

There are four panes in the Formula Editor: Report Fields, Functions, Operators, and the Editor. 

Our formula will be a simple multiplication of two fields. In the Report Fields pane, double click 

on order_line_items.Quantity, then enter a * in the Editor pane, then double-click on 

order_line_items.unit_price. Save the formula and close the Editor.   

You’ll return to the Field Explorer. Drag the new Extend Price field from the Field Explorer and 

place it on the Detail Band to the right of Unit Price.  

Let’s add some totals. Only totals for the Extended Price make sense. Select the Extended Price 

field on the detail band, then from the menu select Insert > Subtotal and click on OK in the Insert 

Subtotal dialog. You could have also checked the “Insert grand total field” check box to add a 

grand total at the end of the report. We’re going to add the grand total from the menu.  

 

To add a grand total, select the Extended Price field in the Detail band. From the menu select 

Insert > Grand Total and press Enter in the Insert Grand Total dialog.  
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Now all the report needs is page headers and a graph. We’ll add the page header first. In the 

Field Explorer, expand the Special Fields entry. Select “Page N of M” and drag and drop it on 

the right edge of the Page Header field. Grab the handle on the left side of the page number field 

and shrink the field so it isn’t too wide.  

Now drag and drop the “Print Date” field on the left edge of the Page Header band. 

Finally, from the menu, select Insert > Text Object and drop it in the center of the Page Header. 

Enter the report name “Sales Detail Report”. One of the few problems of Crystal Reports is that 

there is no easy way to center an object horizontally on a page. However, we can do this in a few 

steps. First, grab the handles on the left and right edges of the report title and expand the field so 

that it goes across the entire width of the page. Then, right-click on the field and select “Format 

Text” from the shortcut menu. In the Format Editor, change “Horizontal Alignment” to Centered 

and click on OK. The report title will now be centered horizontally on the page. You will have to 

change the height of the object if you select a larger font.  
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The final step of our report is to add a graph. Select Insert > Chart from the menu. The Chart 

Expert will be displayed. On the first page, select the type of chart you want. I’ve selected a 

three-dimensional bar chart.  

 

The second page is where you select the data for the chart. Note that Crystal Reports has already 

selected the data for you. We need to change the placement of the chart from Header to Footer. 

When you click OK, the graph will be automatically placed in the report footer.  
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We’ve now completed designing our report.   

 

Click the preview button and let’s look at a couple of things. On the left-hand side, you’ll see the 

Group Tree. If you click on one of the entries, the report will jump to that group.  
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Go to the last page of the report and you’ll see the chart that we made. In this example, there are 

really two many data points to effectively chart the data. However, you will notice that one bar is 

much longer than the others. Move the mouse over the graph and the mouse pointer will change 

into a magnifying glass. Double click on the long bar. Crystal Reports will drill-down to the data 

that makes up that bar. The really exciting thing is that you can give users this same capability at 

runtime!  
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Runtime Reporting 

Once you’ve created your report, you need to provide a mechanism for users to generate the 

report. Crystal Reports runtime is made up of several .DLL files. Which files you need to include 

depends on the content of the report and the options you give to the users. The needed files are 

listed in RUNTIME.HLP in the Crystal Reports folder.   

You have four runtime options for generating your report:  

Á Print Engine API. This is the oldest method provided and difficult to use. It was 
originally designed for C programmers.  

Á ActiveX Control. Drop the ActiveX control onto a form, set a few properties, and 
youôre ready to go. However, the ActiveX control is a wrapper for the Automation 
Server and does not expose all the properties and methods.  

Á Automation Server. Easy to use.  
Á Report Designer Control (RDC). The newest and best way to run reports. This 

automation server provides all the functionality that you need.  

Crystal Decisions recommends that you use the RDC. The other options have not been updated 

for several versions. The RDC consists of three components:  

Á Report Designer. Gives report creation capabilities to your users. However, this 
option is not royalty free.  

Á Crystal Reports Print Engine (CRPE). This is the actual printing engine. You can 
distribute this piece royalty free.  

Á Report Viewer. Print Preview control. You can also distribute this component 
without additional royalties.  

You should also become familiar with the developer help files as they provide important 

information for creating and distributing Crystal Reports solutions. The four files are:  

Á Developer.Hlp. Contains information on the objects, properties, and methods of 
the runtime engine.  

Á Runtime.Hlp. Lists the DLL files required.  
Á Royalty Free Runtime.Hlp: Information on royalty-free distribution.  
Á Royalty Required Runtime.Hlp: Information on runtime components that require 

additional royalties.  

You will need to distribute the required Crystal Reports runtime files and the .RPT files that you 

created. The following code shows how to open a report and export it to an Excel file.  
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* Create the CR Object  

loCr = CREATEOBJECT("CrystalRuntime.Application")  

 

* Open the re port  

loCrRpt = loCr.OpenReport("C: \ CR\ Cust.Rpt")  

 

* Set the data location  

loCrData = loCrRpt.Database  

loCrTables = loCrData.Tables  

loCrTables.Item(1).Location = "C: \ CR\ Customer.DBF"  

 

* Set the export options  

loExportOptions = loCrRpt.ExportOptions  

loExpor tOptions.DestinationType = 1 && crEDTDiskFile  

loExportOptions.FormatType = 29      && crEFTExcel80  

loExportOptions.DiskFileName = "C: \ CR\ Export.XLS"  

 

* Export the file  

loCrRpt.DiscardSavedData()  

loCrRpt.Export(.F.)  

 

* Manual garbage collection  

loExportOptio ns = NULL  

loCrTables = NULL  

loCrData = NULL  

loCrRpt = NULL  

loCr = NULL  

You will probably want to give your users the ability to preview a report. Crystal Reports also 

has a powerful runtime viewer that provides the same capabilities to the Preview window in the 

designer. This includes the ability to drill-down into the data. Before looking at the code, create a 

form and add two custom properties, oCrystalReports and oReport. Then paste the following 

code into the proper form methods: 

* --  Form.Init  

WITH This  

      * Instantiate Crystal Runtime  

      * and add the report viewer to the form  

      .oCrystalReports = CREATEOBJECT("CrystalRuntime.Application")  

      .oReport = .ocrystalreports.OpenReport("C : \ cr \ cust.rpt")  

      .AddObject("oleCRViewer", "oleControl", "crViewer.crViewer")        

 

      WITH .oleCRViewer  

            * Set report viewer properties  

            .Top = 1  

            Left = 1  

            .Height = ThisForm.Height -  2 

            .Wi dth = ThisForm.Width -  2 

            .ReportSource = ThisForm.oReport  

            *.EnablePrintButton = .F.  

            .ViewReport()  

      ENDWITH 

ENDWITH 
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* ---------------  

 

* --  Form.Resize  

WITH This  

      .oleCRViewer.Top = 1  

      .oleCRViewer.Left = 1  

      .oleCRViewer.Height = .Height -  2 

      .oleCRViewer.Width = .Width -  2 

ENDWITH 

 

* ---------------  

 

* --  Form.Error  

IF nError != 1440  

      * Error 1440 is caused by the Crystal Report Viewer  

      * when you try to display it before the report is don e 

      * loading. We'll ignore it and trap all other errors.  

      DODEFAULT() 

ENDIF 

 

* ---------------  

 

* --  Form.Destroy  

WITH This  

      .oReport = NULL  

      .oCrystalReports = NULL  

ENDWITH 

Now run the form. 

Subreports 

One of the most powerful features of Crystal Reports is subreports. Basically, subreports are 

reports embedded inside other reports. Specifically, subreports: 

Á are a report within a report  
Á can have their own data source  

Á are inserted as objects into a primary report  
Á cannot stand on their own  

Á can be placed in any report section  

Á cannot contain another subreport  

Additional Features 

Crystal Reports has a number of additional features. The most interesting of these is web 

reporting.  

Web Reporting 

Crystal Reports web reporting supports the following web servers: 
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Á Micorosoft Internet Information Server (IIS) or Personal Web Server  
Á Netscape  

Á CGI (Apache)  
Á Lotus Domino  

Your web users can also have the same previewing capabilities that we saw above using a 

FoxPro form. The viewer is downloaded to the web browser in one of the following formats: 

Á ActiveX control  
Á Java using browser JVM  

Á Java using browser plug-in  

Á Netscape plug-in  

Á Standard HTML  

Á HTML with frames  

Á DHTML  

Crystal Dictionary 

The Crystal Dictionary allows you define what portions of the database you want the user to see. 

You can limit fields, provide captions, help, and relations. Users that design their own reports 

can only see the parts of the database that you’ve defined 

Crystal SQL Designer 

The SQL Designer allows you to create the SQL Statement then have Crystal Reports run it 

against your data source. You can use the wizard to enter the SQL SELECT statement directly. 

Summary 

Providing users with simple or complicated reports is easy with Crystal Reports. Users can then 

preview, print, or export the report to a number of different formats. If you don’t have Crystal 

Reports in your Developer Toolbox, you should take a serious look at it. You can find Crystal 

Reports on the web at http://www.crystaldecisions.com 

. 

 

http://www.seagatesoftware.com/

